You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

33 lines
558 B
Nix

{
config,
pkgs,
flakePath,
...
}: let
symlink = fileName: {recursive ? false}: {
source = config.lib.file.mkOutOfStoreSymlink "${flakePath}/${fileName}";
inherit recursive;
};
in {
programs.neovim = {
enable = true;
vimAlias = true;
viAlias = true;
defaultEditor = true;
withNodeJs = true;
extraPackages = with pkgs; [
tree-sitter
lazygit
];
};
home.sessionVariables = {
SUDO_EDITOR = "nvim";
};
xdg.configFile = {
"nvim" = symlink "home/apps/nvim" {recursive = true;};
};
}