mirror of https://github.com/sgoudham/website.git
You cannot select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
27 lines
543 B
Nix
27 lines
543 B
Nix
{
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs";
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
};
|
|
|
|
outputs = {
|
|
nixpkgs,
|
|
flake-utils,
|
|
...
|
|
}:
|
|
flake-utils.lib.eachDefaultSystem (
|
|
system: let
|
|
pkgs = import nixpkgs {inherit system;};
|
|
in {
|
|
devShells.default = pkgs.mkShell {
|
|
name = "yarn-shell";
|
|
buildInputs = with pkgs; [
|
|
nodejs_20
|
|
(nodePackages.yarn.override {inherit nodejs_20;})
|
|
dive
|
|
];
|
|
};
|
|
}
|
|
);
|
|
}
|